HiPOS 5.0 Brother标签打印机不出杯贴?

故障现象

April 9, 2022 喜茶IT钉钉报修

HiPOS 5.0 喜茶门店标签打印机自检正常(可以打印测试页),周边设备检查正常,重印标签不打印


【处理过程和原因分析】

初步判断,HiPOS本地自检正常,说明标签打印机的连接和配置正确,不打印标签的原因另外二个原因

- 商品SKU 没有配置

- 标签打印路由配置不对

- ...

步骤#1. 【 收集信息了解问题订单号  ⭐

现在门店标签机不出杯贴对吗?给一个订单号给我

 步骤#2、 日志检查】分析HiPOS本地日志  ⭐⭐⭐⭐⭐

从POS Log中分析主档拉取,没有获取到打印机配置 

HiPOS本地Log日志

 步骤#3、配置检查】进入后台查看外设配置  ⭐⭐⭐

HiPOS 云端外设配置

 步骤#4、配置检查】进入后台查看标签路由配置 ⭐⭐⭐

-----发现路由配置中没有故障门店,所以确认 需要在路由配置中添加门店信息

HiPOS云端路由配置

 步骤#5、验证和回访】门店重启HiPOS 标签打印正常 ⭐⭐

回访和通知喜茶IT

【问题总结】

一个简单的问题,我们需要经过5步, 其中一步是需要专业人员分析,2步需要进过培训的IT人员分析,
即使我们将处理手册写的再详细,用户的IT也没有专业的人员会分析日志,我们要思考如何将2-3步可以通过一个工具来解决呢?

Is this article helpful?
5 1 1

回复 (3)

照片
30

从问题过程来看,HiPOS在客户端APP没有明确的提醒云端的配置问题;

我们能否在客户端或云端给出清晰明确的提醒:

- HiPOS 在线监控

- 打印机自检页或者【设备状态】中可以快速定位

照片
27

【案例分享】王柠深圳坂田店明天开业,今天美团测试下单打印不出小票和杯贴,看下什么原因?

【处理步骤】

  1. 先让小程序这边看下美团单子推过来没有
  2. 推送过来,报错了,找不到店铺,是不是没有在后台关联店铺
  3. 登录SaaS.hexcloud.cn 管理后台 -- 门店管理 -- 门店开关配置,美团门店列表【绑定门店】,输入故障门店编码
  4. 已经和门店确认,现在打印正常了

【原因分析】

- 是门店主数据和外卖渠道没有匹配导致。

照片
31

【案例分享】喜茶北京昌平永旺店,小程序下单 8504打印不出杯贴,是什么原因?

【处理步骤】

1.获取订单对应的ticketid,方便在日志中准确定位哪笔订单发生了问题

2.从后台获取LOG日志,

分析日志:从日志中发现 有error:nats 错误返回 not found get blessing_takeout_kitchentoFrom206 template failed的错误,

错误说明:后台杯贴模版toFrom206未配置,

3.需要在后台配置toFrom206的定义杯贴模板,配置完成后,需要重启POS,重新打印该笔订单。

【原因分析】

后台未配置相应的杯贴模板,导致杯贴打印不出。

照片
27

很棒,我们逐渐汇总问题和解决方案,下一版再更新主文章!

照片
发表评论
 
附上文件